Liza Rifan Muazin - Tutorial Komputer, Jaringan, Server Dan Perkembangan Teknologi Masa Kini
News Update
Loading...

Sunday, January 26, 2020

Cara Mengatasi Masalah Breadcrumb Search Console Terbaru

Cara Memperbaiki Masalah Breadcrumb Di Search Console - Breadcrumbs merupakan sebuah navigasi yang ada pada suatu website untuk membantu pengunjung mengetahui lokasi saat mengunjungi website tersebut.

Cara Mengatasi Masalah Breadcrumb Search Console Terbaru


Breadcrumb berfungsi untuk menyempurnakan navigasi yang ada pada blog seperti halnya homepage (halaman utama), kategori, tag, ataupun yang lainnya.

Jadi misalnya kita sedang membaca sebuah artikel di blog, maka breadcrumb inilah yang menunjukan kita sedang berada di dalam kategori apa, tag apa ataupun yang lainnya.

Berikut contoh breadcrumb yang ada di blog saya.

Contoh Breadcrumbs Di Blog https://www.lizarifan.id
Contoh Breadcrumbs di Blog Saya


Setelah kita memahami apa itu breadcrumb barulah saya akan membahas tentang masalah yang terjadi.

Baru-baru ini banyak sekali kawan blogger yang mengalami masalah yang sama yaitu mendapat email dari search console bahwa terdeteksi kesalahan di breadcrumb.

Berikut email yang saya dapat.


Breadcrumbs masalah terdeteksi search console
Email dari search console

Untuk mengatasi masalah tersebut cukup mudah. Kita hanya perlu mengedit bagian breadcrumbs yang ada di template blog.

Masuk ke menu template kemudian pilih edit HTML.

Cari kode berikut.


<b:includable id="breadcrumb" var="posts"> ...sampai dengan penutup ... </b:includable>

Kemudian hapus dan ganti dengan kode berikut.


<b:includable id='breadcrumb' var='posts'>
<b:if cond='data:view.isPost'>
 <b:loop values='data:posts' var='post'>
  <div class='breadcrumbs' itemscope='itemscope' itemtype='https://schema.org/BreadcrumbList'>
   <span itemprop='itemListElement' itemscope='itemscope' itemtype='https://schema.org/ListItem'>
   <a expr:href='data:blog.homepageUrl' itemprop='item' title='Home'>
   <meta content='1' itemprop='position'/>
   <span itemprop='name'><b:switch var='data:blog.locale'><b:case value='id'/>Beranda<b:default/>Home</b:switch></span></a>
   </span>
   <b:if cond='data:post.labels'>
   <b:loop index='nomor' values='data:post.labels' var='label'> &amp;nbsp;&#8250;&amp;nbsp;
     <span itemprop='itemListElement' itemscope='itemscope' itemtype='https://schema.org/ListItem'>
    <meta expr:content='data:nomor+2' itemprop='position'/>
    <a expr:href='data:label.url + &quot;?&amp;max-results=8&quot;' expr:title='data:label.name' itemprop='item' rel='nofollow'>
      <span itemprop='name'><data:label.name/></span>
    </a>
     </span>
   </b:loop>
   <b:else/>
   &amp;nbsp;&#8250;&amp;nbsp; <span itemprop='name'><data:blog.pageName/></span>
   </b:if>
  </div>
 </b:loop>
<b:elseif cond='data:view.isPage'/>
 <div class='breadcrumbs' itemscope='itemscope' itemtype='https://schema.org/BreadcrumbList'>
  <span itemprop='itemListElement' itemscope='itemscope' itemtype='https://schema.org/ListItem'>
  <a expr:href='data:blog.homepageUrl' itemprop='item' title='Home'>
  <meta content='1' itemprop='position'/>
  <span itemprop='name'><b:switch var='data:blog.locale'><b:case value='id'/>Beranda<b:default/>Home</b:switch></span></a>
  </span> &amp;nbsp;&#8250;&amp;nbsp; 
  <span itemprop='itemListElement' itemscope='itemscope' itemtype='https://schema.org/ListItem'>
  <meta expr:content='data:num+2' itemprop='position'/>
  <a expr:href='data:blog.url' expr:title='data:post.url' itemprop='item'>
    <span itemprop='name'><data:blog.pageName/></span>
  </a>
  </span>
 </div>
</b:if>
</b:includable>

Jika sudah jangan lupa simpan template.

Langkah terakhir yaitu masuk ke webmaster / search console. Kemudian pilih validasi perbaikan pada masalah breadcrumb.

Validasi Perbaikan Breadcrumb Google Webmaster
Validasi Perbaikan Breadcrumb

Wednesday, September 4, 2019

Cara Membuat Hotspot WIFi Di Windows Menggunakna CMD

Cara Membuat Hotspot WIFi Di Windows Menggunakna CMD - Pada sistem operasi windows kita dapat membuat wifi hotspot tanpa aplikasi, yaitu dengan menggunakan cmd. Hotspot yang kita buat dapat digunakan untuk sharing internet, sharing data, remote desktop, dan lain lain.

Oke langsung saja kita buat commandprompt sebagai admin.

Pilih start menu kemudian klik kanan pada command prompt, pilih run as administrator

command prompt run as administrator


Cek apakah laptop anda support untuk membuat hotspot, ketikan di command prompt sintak berikut.


netsh wlan show drivers

Lihat bagian hostednetwork supported, jika tertulis yes itu tandanya laptop anda support. Berikut gambar penjelasanya.

Cek Driver HostedNetwork Command Prompt

Langkah selanjutnya seting hotspotnya, silakan ketik sintak berikut.


netsh wlan set hostednetwork mode=allow ssid=WinteknoStudio key=12345678

Penjelasan :
ssid : nama dari wifi yang dibuat
key : password wifi

Sampai disini seting wifi hotspot sebenarnya sudah selesai, namun jika dicek wifi tidak mucnul. Kita harus start wifi terlebih dahulu.


netsh wlan start hostednetwork

Seting Wifi Hotspot CMD WIndows

Sekian tutorial dari saya, jika masih ada yang kurang jelas, silakan tanyakan saja di kolom komentar.


Monday, September 2, 2019

Pengertian Algoritma Pemrograman Komputer

Pengertian Algoritma Pemrograman Komputer

Pengertian Algoritma Pemrograman Komputer - Algoritma merupakan istilah yang pertama kali kita kenal ketika ingin belajar tentang pemrogramman. Begitu juga dengan saya, saat pertama kali mengikuti pelajaran pemrograman dasar, materi yang diberikan yaitu algoritma.

Saya masih ingat betul saat itu guru yang mengajar yaitu Pak Adi, karena beliau lah saya paham algoritma. Dan sampai saat ini masih ingat. 

Pengertian algoritma yang beliau ajarkan yaitu.

Algoritma adalah urutan langkah penyelesaian masalah secara logis dan sistematis.

Cukup sederhana, namun memang begitulah algoritma yang sebenarnya. Logis yang dimaksud dapat dinalar atau masuk akal, sedangkan sistematis berarti secara berurutan.

Jadi semua hal yang kita kerjakan sebenarnya menggunakan algoritma. Misalnya ketika kita ingin memasak mie goreng.

Kita harus menyiapkan panci dan air, masukan mie kedalam panci, nyalakan kompor dan tunggu sampai mie matang, matikan kompor dan angkat mie, campur mie goreng dengan bumbu, mie goreng siap untuk dimakan.

Kasus diatas merupakan contoh sederhana, dalam komputer algoritma banyak sekali menyelesaikan kasus yang rumit.

Berikut beberapa bentuk algoritma.
  • Algoritma Sekuensial (Squence Algorithm)
  • Algoritma Perulangan (Looping Algorithm)
  • Algoritma Percabangan Atau Bersyarat (Conditional Algorithm)

Pengertian Algoritma Menurut Para Ahli

Untuk memperjelas pengertian algoritma, berikut pendapat menurut para ahli.

1. Abu Ja'far Muhammad Ibnu Musa Al-Khawarizmi

Al-Khawarizmi (Ahli Matematika), pengertian Algoritma adalah suatu metode khusus yang digunakan untuk menyelesaikan permasalah.

2. Donald Erwin Knuth

Donal Erwin Knuth, pengertian Algoritma adalah sekumpulan auran-aturan berhingga yang memberikan sederetan operasi-operasi untuk menyelsaikan suatu masalah tertentu.

3. S. E. Goodman dan S.T. Hedetniemi

Menurut Goodamn dan Hedetniemi, pengertian algoritma adalah urutan terbatas dari operasi-operasi yang terdefinisi dengan baik, dimana masing-masing membutuhkan memori dan waktu yang terbatas untuk menyelesaikan suatu masalah.


Kriteria Algoritma

  • Ada Input
  • Ada Proses
  • Ada Output
  • Ada Intruksi Yang Tidak Ambigu / Harus jelas
  • Ada Tujuan Yang Hendak Dicapai.
  • Efisien

Fungsi Algoritma

  • Mengatasi permasalah yang rumit dalam pemrograman yang menggunakan perhitungan tingkat tinggi.
  • Membudahkan dalam pembuatan program dengan skala besar.
  • Mudah dalam pengelolaan ataupun pengembangan karena program sebelumnya disusun secara logis dan sistematis.
  • Dapat melakukan pendekatan top down dan juga devide and conquer.
  • Dll

Sekian penjelasan dari saya, jika masih ada yang kurang jelas silakan tanyakan saja di komentar.

Sunday, August 25, 2019

Perbedaan Protocol TCP dan UDP Pada Jaringan Komputer

Perbedaan Protocol TCP dan UDP Pada Jaringan Komputer

Perbedaan Protocol TCP dan UDP Pada Jaringan Komputer - Sebagai network engineer pasti sudah tidak asing lagi dengan yang namanya protocol terutama protocol TCP dan UDP. Kedua protocol ini merupakan protocol yang paling familiar.

Dengan protokol ini kita dapat mengatur trafic pada jaringan, entah akan diblock, diterima, dialihkan atau yang lainnya.

Protocol TCP dan UDP memiliki banyak perbedaan, malah bisa dibilang kebalikannya. Berikut akan saya jelaskan lebih rinci.

TCP (Transmission Control Protocol)


TCP adalah salah satu jenis protocol jaringan yang memungkinkan sekumpulan komputer dapat berkomunikasi / bertukar data satu sama lain dalam suatu jaringan.

TCP memiliki ciri khas yantiu berorientasi koneksi (Connection Oriented). Protokol TCP menggunakan jalur data full duplex yang artinya dalam suatu koneksi terdapat dua buah jalur, jalur terima dan jalur kirim.

Karakteristik TCP


  • Reliable, artinya berurutan. Urutan data pada saat diterima sama dengan urutan data pada saat dikirim.
  • Connection Oriented. Sebelum mengirim data kedua host harus saling sepakat terlebih dahulu kemudian baru membangun koneksi bersama.
  • Full Duplex. Setiap koneksi memiliki dua jalur, yaitu jalur untuk menerima dan jalur untuk mengirim. Dengan demikian kedua host dapat mengirim data secara bersamaan.
  • Flow control untuk mencegah macet pada saat data dikirimkan karena terlalu banyak data yang lewat.
  • Dan lain-lain

Aplikasi Menggunakan TCP


Aplikasi-aplikasi dapat menggunakan protokol TCP maupun UDP, tergantung sifat transmisi data yang berlangsung. Berikut beberapa contoh aplikasi yang menggunakan protocol TCP untuk berkomunikasi.


UDP merupakan protokol jaringan kebalikan dari TCP. Koneksi ini unreliabel & connectionless.  Jika data yang dikirim gagal, protocol UDP tidak akan memberikan pesan bahwa data gagal dikirim.

Data yang dikirim dengan protocol UDP akan dikirim secara datagram tanpa adanya nomor identifikasi. Sehingga ada kemungkinan jika data yang sampai tidak sama urutannya dengan data pada saat dikirim.

Kehilangan data juga sangat mungkin, karena data yang gagal dikirim tidak akan dikirim ulang, tidak seperti pada protokol TCP yang akan mengirim ulang ketika ada data yang gagal.

Karakteristik Protocol UDP


  • Protokol yang ringan
  • Transmisi Broadcast, karena sifat UDP yang tidak perlu saling sepakat untuk membuat koneksi.
  • Tidak adanya segmentasi, sehingga data yang dikirim dengan protocol UDP harus memiliki ukuran yang lebih kecil dari nilai MTU agar tidak terfragmentasi dan menyebabkan data tidak terkirim secara utuh.
  • Connectionless, mengirimkan data tanpa harus dilakukan proses negosiasi antara kedua host.
  • Dain lain-lain.

Aplikasi Menggunakan UDP


  1. DNS (Domain Name System)
  2. SNMP (Simpe Network Management Protocol)
  3. TFTP (Trivial File Transfer Protocol)
  4. SunRPC

Perbedaan Protocol TCP Dan UDP


  • TCP : Dapat diandalkan karena jika jaringan terputus maka akan mengirimkan ulang data yang belum terkirim.
  • UDP : Setiap data yang gagal dikirim akan diabaikan dan tidak dikirim ulang.
  • TCP : Urutan data pada saat dikirim sama dengan urutan data pada saat diterima.
  • UDP : Tidak dapat dipastikan data yang diterima sama urutannya dengan data yang dikirim.
  • TCP : Connection Oriented, sebelum data dikirim harus ada proses sepakat antara kedua host.
  • UDP : tanpa perlu negosiasi untuk membangun koneksi, data langsung dirikim. 
  • TCP : Koneksi lebih berat dan lama karena jika ada data yang rusak akan dikirim ulang.
  • UDP : Koneksi lebih ringan karena tidak ada proses mengurutkan data dan mengirim ulang data yang gagal dikirim.
  • TCP : Tidak cocok digunakan untuk streaming karena koneksi tidak realtime.
  • UDP : Sangat cocok koneksi yang bersifat realtime seperti halnya streaming.

Saturday, August 24, 2019

Memanfaatkan Fitur Buzzer (Beep) Mikrotik Untuk Notifikasi Ketika Internet Down

Memanfaatkan Fitur Buzzer (Beep) Mikrotik Untuk Notifikasi Ketika Internet Down

Memanfaatkan Fitur Buzzer (Beep) Mikrotik Untuk Notifikasi Ketika Jaringan Down - Pada beberapa tipe mikrotik memiliki fitur buzzer yang biasanya digunakan sebagai pemberitahuan / notifikasi ketika jaringan down.

Dengan adanya buzzer ini kita dapat mengatur mikrotik agar berbunyi beep ketika jaringan down, dan akan berhenti berbunyi ketika jaringan sudah normal kembali. Jadi suara beep ini akan terus berbunyi selama jaringan masih down.

Awalnya saya mencari artikel yang membahas tentang ini dan menemukan disalah satu forum bahasa inggris, itupun banyak yang komentar bahwa caranya sudah tidak bekerja lagi untuk mikrotik versi terbaru. 

Berikut trik saya memanfaatkan fitur buzzer / beep mikrotik agar berbunyi ketika jaringan sedang ada masalah dan akan berhenti berbunyi setelah jaringan kembali normal.

Sebelumnya cek terlebih dahulu apakan mikrotik Anda memiliki fitur ini dengan cara mengetikan di terminal winbox /beep

Jika mikrotik mengeluarkan suara itu tandanya mikrotik Anda memiliki fitur buzzer. Pastikan juga mikrotik telah terhubung dengan internet dengan cara ping ke google.

Cek Buzzer dan ping google

Kemudian langkah selanjutnya yaitu membuat scheduler, pilih system kemudian scheduler dan pilih tanda +. Lihat gambar dibawah.

Membuat Scheduler

Yang perlu diperhatikan yaitu nama, pada contoh diatas saya beri nama alarmku. Kemudian interval, disini saya mengaturnya 10 detik, jika merasa terlalu lama atau terlalu cepat silakan sesuaikan saja.

Dan yang terakhir yaitu on event, yatu script yang dijalankan. Berikut scriptnya.



{
:beep frequency=2000 length=500ms;
:delay delay-time=1000ms;
:delay delay-time=1000ms;
:beep frequency=4000 length=500ms;
}
{
:beep frequency=4000 length=500ms;
:beep frequency=2000 length=500ms;
:delay delay-time=1000ms;
}
:delay delay-time=1000ms;

Langkah terakhir buatlah netwatch dengan host dns google (8.8.8.8).

Pilih tool kemudian pilih netwatch dan pilih tanda +.

Membuat Tool Netwatch

Host diisi dengan 8.8.8.8 atau dns dari google. Interval saya isi 10 detik. Jika merasa kurang sesuai silakan sesuaikan saja.

Pada up dan down silakan diisi script berikut.


/system scheduler disable [find name=alarmku]


/system scheduler enable [find name=alarmku]

Taraa...!!!

Konfigurasi telah berhasil, dengan begitu ketika internet down maka mikrotik otomatis akan memberitahu kita dengan mengeluarkan bunyi dan akan berhenti ketika internet kembali normal.


Friday, August 23, 2019

Cara Install dan Konfigurasi Monitorix (Monitoring Server) Di Debian 8

Cara Install dan Konfigurasi Monitorix (Monitoring Server) Di Debian 8

Cara Install dan Konfigurasi Monitorix (Monitoring Server) Di Debian 8 - Monitorix merupakan aplikasi berbasis web yang berfungsi untuk memonitoring sumber daya server. Dengan adanya monitorix ini kita dapat mengetahui prosentase penggunaan cpu, traffic network, dan lain-lain.

Cara konfigurasinya cukup mudah, namun dikarenakan paket monitorix tidak tersedia di dvd debian 8 maka kita harus mendownloadnya secara manual di website resminya.


Dihalaman download terdapat banyak versi, silakan pilih saja yang untuk debian.

Jika sudah, pindahkan file monitorix ke server, terserah mau pakai cara apa. Bisa pakai scp, ataupun ftp. Jika belum tau bagaimana caranya konfigurasi ftp silakan baca artikel berikut.


Jika semua persiapan telah siap, langsung saja mulai install monitorix. Namun sebelum menginstall monitorix ada beberapa yang perlu diinstall.

Install kebutuhan monitorix

Install semua keperluan seperti gambar diatas. Jika kurang jelas silakan lihat kode berikut.



apt-get install rrdtool perl libwww-perl libmailtools-perl libmime-lite-perl librrds-perl libdbi-perl libxml-simple-perl libhttp-server-simple-perl libconfig-general-perl libio-socket-ssl-perl


Setelah terinstall barulah install monitorix, sebelumnya kita harus menuju ke directory dimana file monitorix berada.

Jika sudah ketik perintah berikut.

Install monitorix



dpkg -i monitorix*.deb
apt-get -f install

Installasi berhasil, saatnya restart monitorix


service monitorix restart

Jika tidak muncul error itu tandanya monitorix berhasil terinstall. Langsung saja saat pengujian.

Silakan buka browser dan ketikan alamat seperti berikut

http://ipserver:8080/monitorix

Berikut tampilan monitorix jika berhasil terinstall.

Tampilan Monitorix


Tuesday, August 6, 2019

Pengertian Resistor Dan Fungsinya

Pengertian Resistor Dan Fungsinya

Pengertian Resistor Dan Fungsinya - Resistor adalah komponen elektronik yang memiliki dua pin dan berfungsi untuk mengatur tegangan listrik dan arus listrik pada suatu rangkaian.

Resistor mempunyai nilai tahanan tegangan listrik di antara kedua pin, dimana nilai dari tegangan listrik berbanding lurus dengan kuat arus yang mengalir berdasarkan hukum Ohm.

Resistor merupakan komponen yang paling sering digunapak pada rangkaian elektronik. Resistor dapat dibuat dari berbagai macam bahan, seperti kawat resistensi.

Ukuran dan letak kaki resistor dapat disesuaikan dengan papan sirkuit, kebutuhan dan daya resistor juga harus disesuaikan agar tidak terbakar pada rangkaian.

Resistor tidak memiliki kutub positif maupun negatif, tetapi memiliki karakteristik utama yaitu resistensi, toleransi, tagangan kerja maksimum dan induktansi.

Fungsi Resistor

Fungsi utama resistor yaitu sebagai pengatur dan membatiasi jumlah arus yang mengalir dalam suatu rangkaian.

Dengan demikian kita dapat mengatur kuat arus yang mengalir pada rangkaian agar sesuai dengan kebutuhan.

  1. Berfungsi untuk menahan arus listrik agar sesuai kebutuhan
  2. Berfungsi untuk menurunkan tegangan agar sesuai kebutuhan
  3. Berfungsi untuk membagi tegangan
  4. Berfungsi untuk membangkitkan frekuensi rendah maupun tinggi dengan bantuan kapasitor dan transistor

Jenis-Jenis Resistor

Secara umum resistor dapat dibedakan menjadi beberapa jenis, diantaranya yaitu fixed resistor, variable resistor, thermistor dan LDR.

1. Fixed Resistor

Fixed Resistor adalah jenis resistor yang memiliki nilai resistensi tetap. Nilai resistensi biasanya ditandai dengan kode warna yang ada pada resistor.

Yang tergolong dalam kategori Fixed Resistor bedasarkan Komposisi bahan pembuatnya diantaranya:
  • Carbon Composition Resistor
  • Carbon Film Resistor
  • Metal Film Resistor

2. Variable Resistor

Variable Resistor merupakan jenis resistor yang nilai resistansinya dapat berubah atau disesuikan dengan kebutuhan. Pada umumnya terbagi menjadi potensiiometer, Rheostat dan Trimpot.

Potensiometer merupakan jenis Variable Resistor yang nilai resistansinya berubah dengan memutar porosnya melalui sebuah tuas yang terdapat di potensiometer.

Rheostat merupakan jenis Variable Resistor yang dapat beroprasi pada tegangan yang tinggi. Terbuat dari lilitan kawat resesif dan cara pengaturan dengan penyapu yang bergerak pada bagian atas Toroid.

Trimpot atau Preset Resistor  adalah jenis Variable Resistor yang berfungsi seperti Potensiometer tetapi meiliki ukuran yang lebih keicl dan tidak memiliki Tuas. Untuk mengatur nilai resistansi dibutuhakan alat bantu seperti obeng kecil.

3. Thermistor

Thermistor adalah jenis resistor nilai resistensinya dapat berubah karena pengaruh suhu. Thermistor sendiri merupakan singkatan dari "Thermal Resistor".

Thermistor ada dua jenis yaitu NTC (Negative Temperature Coefficient) dan PTC (Positive Temperature Coefficient).

4. LDR (Light Dependent Resistor)

LDR merupakan jenis resistor yang nilai resistansinya dipengaruhi oleh intensitas cahaya.
Notification
Done